
CotD Release Notes July 2018 - Select Foods Screen 

Summary of Changes 

• The lists of available food items and chosen food items have been merged, making it easier to see which 

foods have been selected for the assessment. 

• More details can be displayed for each food making it easier for the user to select the most appropriate 

food, especially if there are several similar options to choose from. 

• The options for filtering and sorting foods have been improved. 

• Highlighting of newly selected and deselected food records helps to identify the changes that have been 

made before saving the screen. 

• When creating a new food the food group can be selected from all major, minor and sub food groups. 

Using the Select Foods Screen 

Overview 

The Select Foods Screen is accessed through the Add or edit foods link on the Assessment summary or Model 

summary screen. 

• The complete food list with all available and already selected foods is displayed in alphabetical order, with 

the selection checkbox column and the food name, local name, food group and food region columns 

showing by default. 

 

• The currently active record is highlighted in blue and its nutritional details are displayed at the bottom of the 

screen.  

• Already selected foods are highlighted in grey and have a tick in their checkbox. 

Active record 

Selected foods 



• The total number of foods in the database and the number of foods selected for the current model or 

assessment are displayed in the title bar of the food list. 

Displaying Selected Foods Only 

To display the foods selected for the current assessment or model as a list on their own, click the field above the 

checkbox column. Alternatively use the Filter menu > Selected Foods Only. Selected foods are ticked and highlighted 

in grey. Foods that were added during the current session are highlighted in green. 

 

 

 

 

 

 

 

 

 

To return to the complete list of foods click the checkbox column header or the Selected Foods Only option in the 

Filter menu for a second time. 

Displaying Additional Columns 

The default columns displayed are the food name, local name, (major) food group and food region columns.  

To add further columns select More… from the Columns menu and click on the information you want to display.  

 

The column Created In shows whether the food belongs to the 

standard CotD food database (Standard food) or whether it 

was user-created (showing the name of the assessment it was 

created in). 

The column Portion Size shows the standard portion size for 

the (sub) food group the food belongs to. 

To remove columns from the current view  (including the 

default columns) remove the ticks from the Columns menu by 

clicking the ticked options. 

 

Please note: Adding or removing columns clears any filters that may have been set. 

Sorting Columns 

By default the food list is in alphabetical (English) name order. To sort on any other column click the appropriate 

column header.  

This will add an arrow to the column header and sort the food list first on the selected column and secondly on the 

Name column.  

To change the sort order from ascending to descending and vice versa click the column header again.  

Click the top of the checkbox column or select ‘Selected Foods Only’ from the Filter menu Food list displaying only the 

foods selected for the current 

model/assessment  



 

Filters 

Filters are used to restrict the food list to foods that are of special interest. The Filter menu allows to filter by: 

• Selected Foods Only – these are all the foods that have been selected for the current assessment/model. If 

they were selected during the current session (and haven’t been saved yet), they will be highlighted in 

green, otherwise the records are highlighted in grey (see above Displaying Selected Foods Only and below 

Adding a Food to the Assessment or Model). 

• Selection Changed Foods Only – these are the foods that have been selected (green) or deselected (pink) in 

the current session before saving (see below: adding/removing foods). 

• Food Regions – several food regions can be selected at the same time. 

• Food Groups - several food groups can be selected at the same time. Only the major food groups are 

available. 

The Food Regions and Food Group filters can be used simultaneously and together with either of the selected foods 

filters.  

 

 

 

If the food list is filtered on food groups or food regions, details of this are given in the title bar of the food list.  

 

To clear all filters select Filter > Clear Filters. To clear filters individually click them to remove the appropriate tick in 

the Filter menu. Clicking one of the selection filters will automatically remove the other selection filter if set. 

Please note: Adding or removing columns will clear all filters, so make sure to display the required columns before 

setting any filters. 

‘Selection Changed Foods Only’ filter showing all foods 

that were added to the food list (green) and removed 

from the food list (pink) during the current session 

Setting ‘Food Region’ filters 



 

Searching for Foods 

The search function is located above the Nutritional Information section.  

• As soon as the search term is typed into the search box the buttons next to it become active, assisting in the 

search.  

• The search term can be highlighted, and the Find next and Find previous buttons allow to move quickly to the 

next or previous occurrence.  

• To search only for foods starting with the search term, capitalize the first letter and click Match case. 
 

Please note: Foods that were user-added in previous versions do not always start with a capital letter and 

will be at the bottom of the food list. 

 

Adding a Food to the Assessment or Model 

 

To add a food to the assessment/model click its checkbox (to 

the left of the name). The checkbox will be ticked, and the food 

record will be highlighted in green (once it’s no longer the 

active record).  

The number of Foods Selected in the food list title bar increases 

by one, as does the counter of foods added in the current 

session.  

 

 

 

 

 

 

 

 

If the filter option Selected Foods Only is 

ticked the list of displayed foods includes the 

ones that were added in the current session. 



 

Removing a Food from the Assessment or Model 

In the list of selected foods click the checkbox of the food to be removed. This removes the tick, and the food record 

will be highlighted in pink (once it’s no longer the active record). 

The number of Foods Selected in the food list title bar decreases by one, and the counter of foods removed in the 

current session increases by one. 

 

To see all foods that have been selected or deselected in the current session click Selection Changed Foods Only in 

the Filter menu. 

 

If a food is removed from the current model’s food list it will only be removed from the assessment food 

list if it’s not selected for any other model. 

If a food is removed at the assessment level it will also be removed from all models. 

  



 

 

Creating a New Food 

To create a new food from scratch (i.e. if it’s not based on an existing food) click the Create New Food button at the 

bottom of the screen or select the appropriate option from the File menu. 

This opens the Create New Food screen. 

Fill in the details in the three tabs – Food Details, Essential Nutritional Information and Non- Essential Nutritional 

Information. 

 

Food Groups (in the Food Details tab):  

The food group can now be selected not only from the major food groups, but also from any of the minor and sub-

food groups. This ensures that the most appropriate standard portion size is used. For example, the standard portion 

size for the main food group Milk and milk products  is 15g/meal, whereas the standard portion size for the minor 

food group Milk  is 100g/meal. 

The food groups are presented in a tree view with the major food groups showing by default. To reveal the minor 

and sub-food groups click on the node (>) of the appropriate food group in the level above. To select a food group 

click its check box. Its standard portion size will be displayed in the status bar at the bottom of the Create New Food 

screen. 

Food Table:  

The default food table for all newly created foods is Other. To show the country origin of the new food the country 

name can be written in brackets after the food name e.g. Banana (Ethiopia).  

  



 

Conversion Factor ml to g 

For foods such as oil or milk where the weight data during the market survey might be collected in millilitres, a liquid 

conversion factor should be applied.  

• If the conversion factor of the new food is known it can be typed directly into the value box. The description 

will change to User Defined.  

• To use one of the existing conversion factors select the most appropriate food from the drop-down. The 

value can be edited if required in which case the food name would be replaced by User Defined.  

 

 

Iron Coefficient 

 

 

Once all details have been entered on the Create New Food screen, click the Add button to add the food to the food 

database and to the current assessment or model. It will be displayed in the food list, ticked and highlighted in 

green. 

 

Cloning an Existing Food 

To base a new food on an existing one click the Clone Existing Food button at the bottom of the screen. This will 

open the Clone Food Form which is largely unchanged from the previous version. 

After selecting a food to clone check the three tabs and edit any values that need changing. The food name has to be 

changed before the food can be saved to avoid confusion with the original food. 

After cloning the food the clone is added to the food database and is automatically selected for the current 

assessment or model (highlighted in green). 

 

 

 

Conversion factor of ‘Cream, whipped’ applied Conversion factor entered directly or edited by user 

To apply the iron absorption factor select the appropriate 

food group from the Iron Coefficient drop-down menu. This 

ensures that the software takes into account the reduced 

bioavailability of iron from the diet.  

The value can’t be edited by the user. 

 

 



 

Editing a User-Created Food 

 

Deleting a User-Created Food 

User-created foods can be deleted from the system by clicking the Delete Food button at the bottom of the Select 

Foods screen with the food highlighted in blue in the food list.  

The Delete Food button is only available at the assessment level. 

This option should only be used if you intend to delete the food from all assessments as it will be permanently 

deleted from the food database. A warning message will appear explaining the consequences. 

Deleted foods will appear greyed out in the food list until the Select Foods screen is saved. 

 

Viewing the Food Database 

To view the food database select the appropriate option from the File menu. 

 

Saving the Select Foods Screen 

Before saving the screen you can check which changes were made in the current session by setting the filter to 

Selection Changed Foods Only (see above under Filters).  

To save all changes made to the Select Foods screen click the OK button in the bottom right hand corner.  

If foods were selected in the current session the Allocate Foods to Models window will come up. It allows you to add 

a price and edit the portion size and consumption frequency for each food, and, if the food was added at the 

assessment level, to select the models it should be added to. 

To proceed saving the changes click OK in the Allocate Foods to Models window. To return to the Select Foods screen 

click Cancel.  

To leave the Select Foods screen without saving the changes click the Cancel button in the bottom right hand corner. 

Any unsaved newly created or cloned foods will not be added to the food database, and deleted foods will not be 

deleted from the food database. 

 

To edit a user-created food highlight it in the 

food list and click the Edit Food button at the 

bottom of the screen (which is only enabled for 

user-created foods).  

This opens the Edit Food screen where any of 

the food details in the three tabs can be edited.  

To save the edited values click OK. 

To exit the screen without saving the changes 

click Close. 


